Solved

My free time on Google calendar is not showing in Calendly

  • 2 April 2024
  • 5 replies
  • 57 views

I set available hours, activated it on my event type, connected Google calendar, but my free time doesn’t show on Calendly. Troubleshooting tool is no help either.

For example, I have Fridays available as 9AM-5PM EST. Troubleshooting tool says “Fridays are set to unavailable in this event type's availability settings in Eastern Time - US & Canada.” This is not correct.

icon

Best answer by Kelsi at Calendly 2 April 2024, 23:43

View original

5 replies

Userlevel 6

Hey there @Krishna72465 - thanks so much for your post! I’m so sorry to hear this is happening - but am confident that with minimal troubleshooting we can get you sorted and back to easy scheduling! 🤗 I know that this is frustrating and your time is valuable, so let’s figure it out! 

I’m glad to hear you are already aware of the Troubleshooting availability tool on your scheduling page (it’s generally very helpful and accurate - but things can and do go wrong, sometimes!). I am going to go over a few different things that could be going on, here, in hopes of resolving your availability issues. If you work through all of this info and are still stuck, just let me know - I’ll be here to dig deeper! 🕵🏼

Here’s what I suggest looking at first: 

  1. Double check the available hours that you have set up under the applied schedule for the event type (do you have Fridays set to “free” and are they free in your connected Google Calendar?)
  2. Double check your connected calendars under “check for conflicts” on your Calendar Connection page (be sure the correct sub-calendars are selected)
  3. Within the Google sub-calendars being checked for conflicts, make sure there are no “busy” events (on the sub-calendars themselves) marking you as unavailable when you expect to be free in Calendly

If you happen to see “Calendar” as an error when using the troubleshooting tool (see below): 

 

 

 

 

 

 

 

This means that an event on your connected calendar is blocking off the time (and this can apply to entire days/weeks/months, depending on the Calendar event).

Using Google Calendar (because you are using Google Calendar) as an example: 

Calendly will view your Google events with this "busy" event status as scheduling conflicts and will automatically remove the time from your scheduling page (including all-day or multi-day events). You can access and change this setting by double-clicking on the event id in your calendar and changing the status from "busy" to "free" as shown below:

 

 

 

 

 

 

 

 

 

 

If you are noticing entire days/weeks marked unavailable on your booking page: when this happens, it's usually because someone has a little event across the top of each day spanning days, weeks or months, which could be PTO, daycare/school for a child, a reminder to take their medication or something else common to do daily that doesn't actually mean you're unavailable but has been accidentally marked as busy. Take a look at your calendar for something like this. If that exists, edit it to mark yourself as free or delete it. It’s also common to have an entire day marked as “busy” because a Google Calendar event marked “busy” spans the entirety of the Calendly availability for that day.

Example: 

  • Friday availability in Calendly is set to 9a-5p EST 
  • Recurring “Busy” Google Calendar event on Fridays - goes from 830a-5p
  • This results in Fridays being marked entirely unavailable in Calendly

If the above does not help you resolve your issue, check out more below! 🗓


The fact that you are using this tool and (per the example you gave) being told that “Fridays are set to unavailable in this event type’s availability” makes me wonder something.

Is it possible that you set up your Availability Schedule under your availability tab, but forgot to apply the desired schedule to the specific event type in question from that tab? 

If you set up your Availability Schedule under your “Availability” tab (and not within the event type itself) it’s possible you missed one small step that we see users miss somewhat commonly.

The “Active on” dropdown at the top of the availability tab (where you can create schedules) is used to apply schedules under this tab to event types. Once you’ve used that dropdown to apply schedules to event types you must hit “Save” for the schedule to appear on the event type’s live booking page.

Click “Active on” dropdown in order to apply availability schedules to event types
Select desired event types > click “Save” to apply availability schedule

My last guess would be that you missed this step - and once you go back and use that dropdown to apply your schedule to the event type, you’ll see that availability on your booking page.


If none of this resolves your issue - I’m sorry to hear it! - but we can keep digging, no problem at all. Go ahead and share a screenshot of what you are seeing when using your availability tool along with the following: 

  • A specific booking page link and a future date and time where this behavior is occurring
  • A screenshot showing that date and time from your Google Calendar, as shown at https://calendar.google.com/, in Week view with the sidebar (showing which calendars are enabled) visible? For example:

Please feel free to blur out/otherwise make unreadable any personally identifying info such as names, email addresses etc. in the calendar screenshot. If you are not using Google Calendar please provide the same/comparable info/screenshots from the connected calendar that applies to your use case! 😊

We’ll get to the bottom of it.

I do hope this helps! 

Kelsi, thanks for the prompt response. The following worked in my case:

  1. setting an event as “Free” instead of “Busy”
  2. Removing all day events

#2 especially is a problem. Users should have the option of including or excluding all day events in scheduling. People use this space as reminders, key events for the day etc. Hopefully, this will be provided as an option to users in the future.

 

 

Userlevel 6

#2 especially is a problem. Users should have the option of including or excluding all day events in scheduling. People use this space as reminders, key events for the day etc. Hopefully, this will be provided as an option to users in the future.

Hey Krishna!

I’m so glad you were able to free up your availability - that is excellent news for sure!

I do want to offer some clarity re: 

  • removing “all day” events 

You do not have to remove these events from your Google Calendar. They simply cannot be marked “busy” if you want to be able to book over them! If you are running into issues where “all day” events marked “free” are still being read as conflicts by Calendly: 

  • try giving the “all day” events on Google Calendar start and end times i.e. beginning at 12:00am and ending at 11:59pm, or
  • try making the “all day” event span over the course of 24 hours i.e. beginning at 12:00am Monday and ending at 12:01am Tuesday

That said - as long as an event is marked “free” it should not cause problems. I hope this helps! Have a great night. 🌜

This worked wonderfully. Thanks a lot. I was ready to give up on Calendly. The troubleshooting tool is practically useless.

If the user could access this article at the calendar settings page itself, it should save a lot of time, reduce frustration and help in conversions. Imagine how many are just giving up versus reaching out to the community. 

Userlevel 6

This worked wonderfully. Thanks a lot. I was ready to give up on Calendly. The troubleshooting tool is practically useless.

If the user could access this article at the calendar settings page itself, it should save a lot of time, reduce frustration and help in conversions. Imagine how many are just giving up versus reaching out to the community. 

I am SO glad it worked for you! YAY! I appreciate the feedback, as well! I do think that if you’d seen “calendar” on your Troubleshooting tool the first time around, you’d have been able to figure out that “busy” events on your Google Calendar were the issue. What do you think, though? That’s what I am more interested in knowing - genuinely! I can make sure that feedback is seen by more than just me. Thanks! 

Reply